Could not execute dot; may need to install graphviz.错误的解决方法

Go qloog · 2020年02月03日 · 1598 次阅读


事情的过程是这样子的:

我需要通过下面的命令来看下程序的执行情况:

go tool pprof -http=:5000 cpuprofile.out .

打开浏览器后发现报下面的错误:

Could not execute dot; may need to install graphviz.

根据提示得知需要安装这个软件graphviz

我的macOS系统,所以可以通过brew install graphviz 来进行安装

安装完后,刷新浏览器问题解决。

graphviz的下载地址是:http://www.graphviz.org/download/